Disable Motion Waking a Notecard at Idle

I have reset my Notecard back to factory defaults and i am running it in an low power app with a SWAN, with idle current of 12uA.

However, if i tilt or bump the setup, the Notecard wakes, and a simple bump, draws more than 2mins of idle current current. Tilting the sensor quickly 90deg and back (over 1s) draws equivalent of 10mins of idle current.

This is solely the notecard waking, not the Swan. I have no ATTN for motion. I have set no card.motion.* settings after factory reset.

If my app were mounted where there is finite vibration or intermittant bumps, or for example is exposed to high winds, i am going to be burning up battery for nothing!

I cant see any setting that completely disable motion stuff completely. If you can’t disable it, then it seems like its something that should be added as a feature.

Bump Notecard

Tilt +90deg - Tilt back - Replace on Table

Hi @SSPW,

Issuing the "stop":true argument to card.motion.mode should disable the accelerometer entirely:

{
  "req": "card.motion.mode",
  "stop": true
}
1 Like

Ok ill give that a try.

I looked at the card.motion.mode settings, and nothing at about “start”:true being a default setting is mentioned.

It would be really nice if the Notecard API reference had a summary table of the all the “factory default” settings.

3 Likes