Can't connect debug adapter to Swan

Hi All,

I have been using VScode + PlatformIO with the STLINK V3-MINIE debug adapter do develop and configure Swan boards. My adapter has a USB C connector. I am using a Windows 10 PC with a USB 3 port.

Today I started up VS Code, and waited for various updates. When I tried to load the firmware, I got the message:

Error: libusb_open() failed with LIBUSB_ERROR_NOT_FOUND
Error: open failed
in procedure ‘program’
** OpenOCD init failed **
shutdown command invoked

I have tried different USB cables. In device manager, the debug adapter appears as two devices; A USB serial device and a an ST-link debug adapter.

I have also tried to upload using DFU via the Swan USB connector. I have never been able to make that work.

Is there a setting in VScode or PlatformIO I need to change? Could it be that my debug adapter is faulty?

Thanks in advance,


Hi again,

It is a Windows problem, or a cable problem. I just moved everything to my Mac and it just worked.

It had been working previously with my PC. If I find the problem I’ll add the fix here.