Error with new notecard library

There seems to be an error with the latest version of the notecard library, I keep getting the error D5 is not declared and some other errors but when I go back to version 1.4.5 the errors cease.

I am using m5 stack esp32 s2 stamp, framework Arduino. I tried both Adafruit Feather s3 no PSRAM and DF robot firebettle S3 board options from the board manager but still got the same error.

1 Like

Hi @Pius4109,

What version of the Notecard library are you currently using?

We recently added some new defines to support our unit-tests and we think there may be a conflict.

Thanks for reporting,


I’ve released a new version of the Blues Wireless Notecard library (v1.5.3), that will eliminate the new testing #define.

It should drop in about 8-12 hours. Once it is released, please give it a try and see if it fixes your compilation issue.

Thanks again,

The latest one. 1.5.2

Yeah, shoot. We had a potential fix setting in a PR that we forgot to merge before the holiday weekend.

I went ahead and merged it just now, then released a new version (v1.5.3). Hopefully, it will get pulled into the Arduino Library Manger soon.

Once you are able to test the fix, we would appreciate if you could let us know if it worked or not.

Thanks again!

1 Like

I just checked, and v1.5.3 is now available from the Arduino Library Manager.

1 Like