GPS is off response

  • I plugged a Pulse W3906 antenna into the Notecard to test GPS functionality (card has functions for months without it).
  • The notecard is near a window
  • I am getting as a response to card.location:
    {‘status’: ‘GPS is off {gps-inactive}’, ‘mode’: ‘periodic’}
    A cellular phone positioned right next to it “sees” 6 satellites, not great but it gets a lat/lon

The response is a bit cryptic:
Is it because my antenna is no good? The GPS circuitry on the notecard not properly enabled?
Is there a way to get more info as to what is going on?


  • switched to a Pi4 running Cat-M1
  • installed an external antenna: External Antenna | Adafruit Ultimate GPS HAT for Raspberry Pi | Adafruit Learning System ( Active Antenna - 3-5V 28dB)
  • using the GPS hat (described above) with that same antenna, same position (i.e. outside, the cord is real long), I read GPS data no problem
  • remove the GPS hat, place the external antenna on the Notecard
  • made sure that the DIP switch on the hat is ON (default)
    → same result as the posting above, GPS is off.
    Obviously I am missing something…
1 Like

Hi @Francois,

Which Notecarrier model are you using? FYI the Notecarrier-A models don’t support external GPS antennas (more info).


@RobLauer I am using the Notecarrier Pi (aka hat). BTW I’ve been given a last minute chance to do some wardriving in Puerto Rico this long weekend, that’s why I’m trying to get the GPS running.

is there a way to debug to see if the issue is with the GPS not acquiring signal or something else happening?

@Francois Do you have access to another Notecarrier, or do you just have the Notecarrier-Pi with you?

While I expect the antenna you have selected to work, there are a number of variables here, and would like to see if we can eliminate the Notecard as the source of the problem.

I have a Notecarrier B (I think), the one that is about the same size as the Notecard. I have connected now to my laptop with the Pulse W3906 antenna. Same result – which is why I am thinking I might be missing something totally obvious:

> {"req":"card.motion.mode"}
> {"req":"card.motion.mode","start":true,"seconds":2,"sensitivity":4}
> {"req":"card.motion.mode"}
> {"req":"card.location.track"}
 "file": "gps.qo",
 "start": true,
 "minutes": 60
> {"req":"card.location.track","file":"gps.qo","start":true,"heartbeat":true,"hours":1}
 "file": "gps.qo",
 "start": true,
 "minutes": 60,
 "heartbeat": true
> {"req":"card.location.track"}
 "file": "gps.qo",
 "start": true,
 "minutes": 60,
 "heartbeat": true
> {"req":"card.location"}
 "status": "GPS is off {gps-inactive}",
 "mode": "periodic"

can you do a screen share?

Yes, contacting you on Skype

@Francois Can you attach the external GPS antenna to a metal surface?

Often with these external patch antennas there’s an expectation of a ground plane which is assumed if it is attached magnetically. One of our engineers does lots of testing with an external patch antenna, but it is mounted to a metal plane. We haven’t tested without that plane yet, so we don’t know exactly what impact that will have.

Also, I found out more about GPS lock. The onboard GPS needs at least a 25dB SNR for at least 3 satellites. We may not have been getting that. The standard GPS trace info only shows the max of available satellites. We should be able to use the +gpsmax on the trace info to see the details SNR information.

While I requested the use of +gpsmax, I think I formatted incorrectly.

trace +gpsmax

should do it.

If you can test outside, maybe with the antenna on the roof of a car, I suspect it will improve.

@gwolff I put the external antenna on metallic pot holder (ext has magnet at the bottom). Got 11/11 sats in 41 seconds. No fix.
Then issued the command trace +gpsmax instead of trace on +gpsmax but the info scrolls too fast to tell.
Forum won’t allow uploading .log file, sending to Skype

@gwolff Never got the carrier B to work reliably.
1- Back to the Carrier Pi, switched from 1.0. to 1.1
2- Made sure GPS DIP was Active
3- Place the Adafruit external antenna on a metal surface (antenna has a magnet)
4- Put the antenna outside
5- Tighten the tiny connector on the Carrier for good measure
6- Rebooted
7- Set card.location.mode to continuous (and hub.set to periodic)
8- Waited several minutes

Further testing indicates that 3,4 and 6 are not a factor.
Item 7 is: when hub.set is in continuous and card.location.mode in periodic, it does not acquire/search for the satellites. Possibly because it takes an unusually long time for the notecard to acquire a sat fix (several minutes). Same antenna/position with an Adafruit GPS hat locks in just a few seconds.

Other suggestion:
Given that external antennas (including the recommended Taoglas MA256.A.LBI.001) use SMA connectors, the uFL adapter weight/rigidity does not permit to truly secure the connection to the notecard. Perhaps another connector?

Just clarifying, the trace info you sent me was captured after the first minute or so of operation. Is that correct?

@gwolff I used the tail of the log file. From the times it looks like it begins 20 seconds into and continues to 9+ minutes

Hi Francois. First of all, thank you for the updated log file.

I did get this to our engineering team when you uploaded it and we are still investigating. I will keep you posted of progress.

Thanks very much.

@gwolff back at my office now, I will run the another test with CoolTerm, external antenna and Carrier Pi. While in PR I noticed that it takes a very long time for the Carrier A to get a sat fix after a power off, over 20 minutes even with a clear view of the sky.

Thanks for the feedback Francois. We will probably need to investigate that separately as the Notecarrier A adds an additional variable of a different antenna and RF layout.

We expect customers to be able to use the active antenna and the Notecarrier B or Notecarrier-Pi. We use that combination frequently, and have not seen such weak GPS signal strength. We are wondering if it happens to be the GPS patch antenna you are using. I know you sent a link, but can you confirm the model number? We are interested in testing with the same antenna.

I am using the external antenna from Adafruit:

When used with the GPS hat Adafruit Ultimate GPS HAT for Raspberry Pi A+/B+/Pi 2/3/Pi 4 [Mini Kit] : ID 2324 : $44.95 : Adafruit Industries, Unique & fun DIY electronics and kits it was amazingly accurate and rapid.

Using the Notecarrier Hat + an external antenna GPS does not get a fix in the following configuration:

I do see the motion events routed to notehub but there is no location available in a {“req”:“card.location”}
The only way to make this work is to first set the card.location.mode to continuous, wait after power on for a fix (7 minutes or so), then switch back to the configuration above.

Thanks very much Francois. I did get the log and am reviewing now.