Is my Notecard broken or my Raspberry Pico

I’m using a Notecarrier-A, Notecard, and Raspberry Pico. My system worked fine for some initial trials using this youtube guide . Then after shuffling things around the workbench, the pi can’t see the notecard anymore. When I scan for I2C I can sporadically find the device. Certainly, one of the components has been damaged.

Is there a way to verify that the Notecard and the Notecarrier are working properly on the Notecard In-Browser terminal?

Hi @tempneff and welcome to the Blues Wireless community!

A good first step would be to connect just the Notecarrier (with the Notecard seated on it) to the in-browser terminal at If you can connect and issue a basic request (something like card.version) successfully, it’s likely the Notecard is just fine.


Thanks Rob,

Looks like it is fine.


Hi again Rob,

Despite this USB test I am unable to connect by SDA and SCL anymore. I have now tried 3 different Raspberry Pi Picos. Is there a way to test these pins on the NoteCarrier?

Sure - there are a few things I would suggest:

  1. Use a simple I2C scanner sketch or this one for MicroPython to see if the Notecard shows up after a scan.
  2. You can use a basic hardware I2C bus scanner too. I’ve had luck with that one.
  3. Send a picture here as well of your setup and we can inspect the wiring just to make sure it all looks good.


Just a litter suggestion…
I had problems with I2C communication in the past, and latter found out that the wires I used had corrosion effect. So make sure there is no such thing in your connections.

1 Like

Thanks again,

I found that If I power it through the 3.3v output in the pico, it doesn’t recognize i2c. BUT, I can get them to talk if I power from the 5v Vbus on the pico.

Is that normal?

Hi @tempneff,

That hasn’t been my experience with the Pico. You’re using the Notecarrier-A, correct? And what are you using to power the Notecarrier and Pico (what’s the voltage input)? Again a picture of your setup might be helpful in this case, just to double check.


Well…I guess it just needed the encouragement…I can’t replicate the problem anymore. Here is my setup anyway…thanks for your help.

It’s like taking your car into the shop and it doesn’t make the same noise. Very frustrating! Please let us know if you experience the issue again.

From your pictures we did notice the location of the Pulse antennas may cause an issue. The antennas need a 12mm diameter “metal-free” cylinder surrounding the core of the antenna. Since breadboards are full of metal contacts, you may have a hard time with getting a cell signal with the antenna sitting on the breadboard. I would let the two antennas hang free over the edge of the breadboard by a significant amount.