Firmware update for notecard v1.1


Are the latest firmwares available for the notecard v1.1?


Hi @Alec, yes indeed. You can follow the steps outlined here to upgrade your Notecards.

The doc is not updated since the “Update” button is not there.

If I select the device and click on “NoteCard Firmware”, I can ask for an update but it’s not updating. I waited few days without success.

The current version is

What do you see in the Notecard Firmware tab for your device? Example below from one of mine that I just kicked off an update for.

I see this:

If I click on “Update Notecard Firmware” I get this:


Last week, I clicked on “Update” for the firmware 1.5.5 but nothing happened for days even if I forced the sync…

Can you try clicking Update for 1.5.5 and keeping an eye on it? The Notecard Firmware tab should update right away letting you know that the update is pending and a download will start with the next sync.

Like I wrote previously, I tried to update this way without success.

I tried again with the same result.

Just to clarify, are you saying that you clicked the “Update” button under 1.5.5 on the Notecard Firmware tab for your device and nothing happened? I want to make sure I understand the issue you are seeing.

I can see the update is pending but nothing happen after multiple manual sync (tried this morning) and automatic sync (tried last week for few days).

Odd. Can you confirm that your Notecard has started a new session with Notehub since you kicked off an update? These will appear as _session.qo events like in the image below:

Yes it has connected since the request.

The current request is at 12h34 and the last seen is 13h10.

Hey @Alec I just noticed that you’re running a pre-GA version of the Notecard firmware, and I suspect the issue is a long since fixed bug that prevented Notecard DFU when a device was operating in continuous mode. You can switch to periodic on the Notecard side, or do a manual update over USB following the instructions here.

I’m already in periodic mode and I would prefer not doing it the manual way…

Hi Alec, I completely understand. However, since you’re running a pre-GA, beta version of the Notecard firmware and we’ve since added a number of features and fixes related to Notecard DFU that are not present on the version you’re running, I suggest taking the manual approach for now. I can confirm that once you get to 1.5.3 or later, the OTA DFU process is quite smooth.

I know the offline approach is a hassle however, so if you would rather jump on a call and I can walk you through it over screen share, I am happy to do so.

1 Like


I did the update but now, there’s an error on the “DFU Status”:

If I click on “Error”, I get this:

However, the cards seem to be working ok.

Did I do something wrong?

Thank you.

Hey Alec, no you didn’t do anything wrong. That “Error” shows up when a Notecard gets an offline firmware update after an OTA is requested. Not a problem in your case.