Not able to install STM32CubeIDE and STM32CubeProgrammer

I downloaded the latest version of STM32CubeIDE and STM32CubeProgrammer and tried installing it in MAC through Terminal as well as directly clicking on the application. I am getting the message the source cannot be trusted and it is not opening. I am attaching the screenshot for the message I am receiving. Please let me know if there are any followup questions. Thanks

1 Like

Hi @samicheen and welcome to the Blues Wireless community!

You’ve run into an annoying error that I’ve also seen in the past. There is a terminal command you can run to fix the issue, documented in this article.

Hi, thank you @RobLauer. After allowing the permission it worked. I missed that. Moreover, MAC is not recognizing the Notecarrier device when I am attaching it with USB. I have already attached Notecard to it and its blinking green as suggested in tutorial. Could you please help with this or shall I create a new post?

Hi @samicheen,

The first thing I would try is a different USB cable. Some USB-A to Micro USB cables are charge-only and don’t support data transfers. If that doesn’t help, let me know!


Yea I thought that as well, but could you suggest which one to take? As I have mobile charger cable. Not sure which one to take.

Yeah it’s unfortunate that charge-only USB cables even exist! Personally I’ve had good experience with Anker USB cables. If you do a search for something like “USB-A to micro USB data cable” you’ll find plenty of options.