Pi 4 Power warning

I am using a Pi hat with wide band Notecard on a Pi 4 with a 3Amp power supply. I am still getting warning message about the power supply. What is the minimum power that is required please.

1 Like

Hi @acsarnaik,

We expect a maximum surge of ~2A, so your findings are a bit surprising. Can you speak to how your Raspberry Pi is configured? Do you have other peripherals, or do you only have a Pi Hat hooked up? Also, are you using standoffs on the Pi Hat to prevent it from shorting on the HDMI output?

We don’t list the max current in our DC Characteristics on the datasheet.

However, under Power Information, it states:

“Furthermore, when in a region requiring the use of GSM, it can spike to up to nearly 2A for a few milliseconds.”

Hello @zfields,
I do not have other peripherals, only the Pi hat. I do not have standoff. Remember this is a Pi4, so the HDMI port is has a fairly good amount of gap. The power supply has 3A capability. This is the wideband Notecard, and has the external antenna. Hope this helps.

That’s all good information! I want to discuss your setup with one of our hardware folks. I will report back once I have more specifics to share.

In the meantime, if you think of anything else that may provide us with a more clear picture, please reply to this thread with those details.


We’ve been using the Pi4 for several months now in a similar configuration.
Some suggestions:

  • Are you using a genuine Raspberry power supply? I know the cost a few more $ but we’ve had issue with other brands. If you are using another brand with a USB cable, we’ve also had issues with, ah, “eBay” cables. In both cases we measured the output at the USB-C end and we could see the voltage dropping.
  • The issue might be on the draw on the HDMI side with 7" or even smaller screen, even with their own separate USB power . Do you see the same issue when you SSH/VNC into your Pi without HDMI?
    What I can confirm is both the narrow and wideband unfortunately draw too much for a Pi Zero – even rebooting the Zero.
1 Like

I am using a good power supply with an attached cable and not a generic one. I have connected the Pi to a LED monitor. I see the same issue when I VNC into the Pi.

Test 1

  • I replaced the 2.5A supply by a 3A Pi4 power supply for my Pi3B+ (less hungry for power).
  • no HDMI, speaker connected, just the ethernet cable
  • Using a Notecard Wideband on a Carrier hat with firmware 12200
    On one SSH I run the following code:
    while true; do vcgencmd get_throttled 1; sleep 1; done
    On another SSH execute a Notecard command, like a hub.set. The code hangs (Python3)
    –> 0x50005 indicating under voltage
    Ctrl-C to break the code
    –> 0x0 (normal voltage)

Test 2
I put the card in periodic mode. That stops code to the Notecard from hanging when the voltage is low.

When the LED light is off (indicating no RX/TX)
–> 0x0
As soon as the LED light goes on
–> 0x50005

NOTE: I am not talking about 2,3 or 4 0x5005, more like a continuous series of 0x5005

I have a USB meter between the power supply and the USB cable to the Pi3B+. I do not see the voltage drop below 5.2v or a substantial change in the amperage. So either my meter doesn’t react fast enough or the issue occurs after the power input to the Notecard.

@ acsarnaik are you using a narrow band or wideband Notecard?

Hello @Francois,

I am using the wideband notecard on the Pi hat. I will try to run the command in a loop to see how it behaves overnight.

Another Pi3B+ is not showing any 0x5005.
I ruled out a few differences:

  • ethernet vs. WiFi
  • 2.5A vs 3A supply
    That leaves
  • narrowband vs wideband
  • Hat vs. USB

My head is hurting… I have a Pi4 with hat+wideband+3A+continuous mode that has no problem. Even when additional code runs on a bonnet.

Same Pi3B+:

  • removed the hat with the wideband Notecard
  • inserted a narrowband with usb
    –> same problem
    So this rules out the usb vs. hat and the wideband vs narrowband
    The 0x5005 occurs exactly at this line of the code:
    port = busio.UART(board.TX, board.RX, baudrate=9600)
    switching to I2C makes no difference:
    port = busio.I2C(board.SCL, board.SDA)

FYI: Thus far I have been unable to reproduce this issue at all
It’s not clear to me yet what the controlling variable is. (Notecard, carrier, Raspberry Pi, etc.)

Here’s my report of what I’ve tried.

Hardware Info


cat /proc/cpuinfo

Response (clipped)

Hardware        : BCM2835

Revision        : a020d3

Serial          : 00000000c964f548

Model           : Raspberry Pi 3 Model B Plus Rev 1.3

OS Info


cat /etc/os-release

Response (clipped)

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"

Power Flag Monitor Command


while true; do vcgencmd get_throttled 1; sleep 1; done

Queries the power status flag every second.

Recommend opening a separate SSH terminal to run this command on the Raspberry Pi

Expected Response (clipped):


Setup Config

Power supply: Samsung 2A phone power supply

Cable: 2 meter USB-A to micro USB





        "org":"Blues Wireless",







        "built":"Dec  7 2020 19:28:29"




    "name":"Blues Wireless Notecard",













        "band":"LTE BAND 12",
















  • Notecarrier-AL
  • Notecarrier-B
  • Notecarrier-Pi

Notecard Comms Interfaces

  • Uart over USB via Node Red with Notecarrier-AL and Notecarrier-B

  • I2C with Notecarrier Pi using Python3 and note-python library

Hub (Cell Network) Connection Policy

Continuous Which means the modem is on continuously.

@acsarnaik you may hold the key to getting to the bottom of this:
Greg cannot reproduce (as you can see above). When I switched my microSD, carrier+notecard+power supply to a new Pi4 – problem solved – it has been running for hours and I can’t get it to report an error.
In my case, I could just forget about Pi3B+ and just use Pi4, but it would be nice to be able to understand why you have an issue on a Pi4.
Can you please run the steps Greg is mentioning above?

Python3 quick utility (version 1.0) to track low voltage:

It looks like using python 3.x instead of python 2.7 has resolved the issue.

1 Like

Good news. Puzzling that 2.7 vs. 3.0 would have an impact all the way down to power warnings.