Card.voltage request reports very high value

I’m reading the Voltage Monitoring part of the Low Power Design under the Notecard Walkthrough.

When I request card.voltage with mode:? I get the following response:
“usb”: true,
“hours”: 7,
“value”: 11.311655963290928,
“vmin”: 5.4,
“vmax”: 5.4,
“vavg”: 5.4

What I take to be the current voltage (value: 11.3+) seems unrealistic. I have done a card.restart, a card.restore, updated the firmware to the latest version ( and still get the same value. I’ve also measured voltages on a number of the Notecarrier pins and get believable measurements (3.36 - 4.5 depending on the pin). I also see the 11.3 value on Notehub for that same device. The highest voltage I can find for all my other devices on Notehub is 5.1, but most are below 5.

What am I missing? If even possible, can the voltage measurement function be reset or am I missing something more obvious? Thanks!

Hi @noforan,

A few questions for you:

  1. Which Notecarrier are you using?
  2. Are you connected directly to the Notecarrier via USB?
  3. Is there anything else wired externally to the Notecarrier? (Maybe sending a picture of your project would be useful, if you have other components attached).


Hi @RobLauer,

Answers to your questions:

  1. It’s a Notecarrier F.
  2. Yes, I’ve connected to the Notecarrier’s USB port and sent commands to it directly using the interface on the Blues website. I’ve also had a test sketch send the same values to the serial monitor when connected indirectly via the Swan’s USB connector.
  3. Yes, mainly sensors which are cross-connected to the Notecarrier via a breadbread. I’ve included a picture but it’s a little busy, so see also the wiring plan.



In case you’re thinking it’s because of something connected to the Notecarrier, I’ve just disconnected everything from the Notecarrier, including the Swan and except the USB, and get this response to the card.voltage query:

“usb”: true,
“value”: 11.309467231131022

Hi @noforan,

What is the USB cable plugged into? A computer or another power supply?

It’s plugged into my Mac via a dongle.

IDK if this is helpful, but taking a closer look on Notehub, the voltage history graph only goes back as far as February 8th, where the voltage is reported to be 11.154. But if you look at the list under Device Health, aside from the entries for boot up, there are only four entries that provide additional information, they are:

Mon 04:58:50 PM: boot ([13982] [11.0] G:P:W~ M:P:W900 U:W0 S:Pc:POWem4 T:W~ I:W~)
Mon 04:46:02 PM: boot (card.restart [13982] [11.0] G:P:W~ M:P:W0 U:W0 R:P S:Pc:POWem4 T:W~ I:W~)
2023-02-12 12:49:45 PM: modem overcurrent (11.15V 25.19C)
2022-11-18 09:19:39 PM: boot (hard reset [13982] [11.0] G:P:W~ M:P:W900 U:W~ R:P:W~ S:W300 T:W~ I:W~)

Note in particular the one on 2/12 that says the modem was overcurrent at 11.15v. I keep fairly detailed notes, and for that day I have nothing for that device, but on the prior day, 2/11 I show that I just completed all the sensor calibrations for that device with no issues noted.

Aside from the voltage reading, I’m not seeing any issues.

Is it possible to query the notecard itself for the voltage history (like you can do for usage), or is it possible to see the voltage history prior to what’s shown on the dashboard (2/12)?

Possibly something happened awhile back, is not still present now, but just noticing it?

Hi @noforan,

Can you send the full schematic of your solution? We’d love to review it in more detail. We are concerned that there is a mixup of 5V (expected) vs 12V (actual) in your wiring, which would’ve supplied too much current to the Notecard and caused these issues.


Sure, but sadly I don’t have a proper schematic…what I do have is this partially hand-drawn “schematic” that depicts a bit more wiring detail. Note that the drawing doesn’t show the TCA9548A board that I added later, after I had already built them to that plan. The TCA board got added because of an issue I had with I2C errors (see that earlier thread in case it’s relevant: Notecard not responding + I2C error messages - #11 by noforan). I can make an updated diagram to include the TCA board, if really needed, but essentially the SDA/SCL lines from the Notecarrier now route to the TCA board and then individual pairs of SDA/SCL mux connections then go to the EZO boards.

I have seven of these devices all built more-or-less identically, and only this one shows this problem, which makes me think that if there’s a wiring problem, it’s probably with this specific device. I have made a custom PCB that replaces the manually soldered breadboard that I started out with, so maybe I’ll replace it with the PCB as a start and see if it resolves it, or at least I’ll need to go back through all the cross-connects to make sure nothing is mis-wired. But that’s all downstream of the Notecarrier.

Where would 12v come from? All the peripheral boards ultimately get power from the Notecarrier 3V3 pin/GND. And the Notecarrier is getting power from one of three sources depending on what I’m doing, either:

  1. The 3.7v LiPO battery / Solar panel – if the device is in the field
  2. The Swan USB / PC – if I’m testing code or doing sensor calibrations
  3. The Notecarrier USB / PC – if I’m checking the Notecard in particular

Do you have maybe a suspicion of what I’d be looking for in terms of bad wiring that would be feeding the Notecarrier 12v? Is it possible for the “downstream” wiring to backfeed the Notecarrier and cause this?

Hello @noforan thank you for all of this information. My original hunch was that you’ve got a DCDC in your red shrink wrap going somewhere on your daughterboard that you didn’t expect. If you are absolutely certain you’re only feeding power to the system via USB (5VDC), then my hunch is ruled out.

I’m looking into this but to answer your question in the meantime- yes you can. First, please see:

Before anything else, is it possible for you to use a multimeter to test all VCC on the breadboard to verify they are within threshold? You mentioned checking all Notecarrier pins, but could you also check your custom breadboard?

If you are able to quickly swap PCBs, I would give that a shot before testing anything with code, but I’ll leave that up to you. If possible, also swap USB cables and verify your USB port is providing enough power to the Notecard.

I believe your issues may be related so thank you for sharing the other thread. I hope above is enough to get you back up and running, but if not, please follow these instructions to do a trace log and share:


1 Like

Hi Tyler,

I measured a number of different points on the breadboard and the highest I could find was 3.358v. I also re-measured a couple different pins on the Notecard and the results were similar to what I saw previously, with the highest being 4.546v at the V+ pin.

I read through the Notecard trace articles and think I ran or enabled the trace, but never saw a save icon in the Notecard playground, only a download icon which does result in a .log file but that simply captures what was displayed on the terminal, nothing additional. In my case, it had:

Welcome to the Notecard In-Browser Terminal.
Start making requests below.
(For advanced info, use the ‘help’ command.)

~ Connected to serial
~ DeviceUID dev:868050045716194 (NOTE-WBNA-500) running firmware

S51:23.13 18 req + 1 rsp = 19 byte network transaction
S51:23.14 sync: work: completed (nothing was pending) {sync-end}
S51:23.14 sync: advancing last sync time from 02:45:15Z to 02:51:25Z
~ Diagnostic sync complete. Use the Save button above to save the results to a file and then send the file to support.

Is there some other command or something else I should be trying to get additional info out of the Notecard?

Also notice that one thing I have tried is to disconnect everything from the Notecarrier, including the Swan and the Adalogger Featherwing, and then query the card.voltage and it still returns the 11.3+v.

Is it possible the measurement logic/circuit is damaged but the Notecarrier/Notecard is otherwise operating properly? Could it even operate at 11.3v if that was truly the voltage?

The red heat shrink you noted is where the signal/one-wire for the two DS18B20s split out before each leave the enclosure. I measured that single wire where it leaves the breadboard and get 3.355v, as well as the + voltage to the DS18B20s and it’s 3.358v.

I’ve not yet swapped out the breadboard but will try that in the next day or so.


@noforan it sounds like your modem may have been damaged. When you touch the modem shield- is it warm? If nothing else is attached to the Notecard and card.voltage is still reporting 11.3VDC, could you repeat your test procedure but with a different Notecard?

I swapped Notecards between Notecarriers (but left everything connected) and the 11.3v follows the Notecard to the other Notecarrier, while the voltage of the 2nd Notecard when placed in the first Notecarrier is around the 4.5v that I’ve measured on the Notecarrier power pins :

> {"req": "card.voltage",
  "mode": "?"}
 "hours": 744,
 "value": 4.76902031138564,
 "vmin": 2.35,
 "vmax": 4.75,
 "vavg": 3.694811827956989,
 "daily": 0.62,
 "weekly": 0.58,
 "monthly": -0.4

As for the temperature, I’ve not noticed it warm to the touch, but maybe better are the historical graphs of temperature on Notehub for both of those under test, first the one that’s @ 11.3v:

And here’s the graph for the second one @ 4.7v:

The “high voltage” Notecard seems slightly warmer at times, almost 35C, but not excessively so.

I have the same problem with one out of 4 notecards. Suddenly the voltage changed to 7.85 volts. The unit had been in continuous service for more that three weeks. Everything continued to work except the card voltage sensor. The voltage (measured on the battery + pin on the note carrier) is normal, but does vary with solar etc. The erroneous card voltage reading varies up and down in sync with the ‘actual voltage’. So perhaps it is a calibration problem.? Bill Neely NFO

Hi @paradox and welcome to the Blues community!

We may need to swap out your Notecard so the team can perform some hardware analysis. Can you please reach out to directly?