`trace` doesn't work over USB for v6.2.2


I just upgraded a notecard to 6.2.2, and I can no longer get any response over USB (ttyACM0). I am connecting using: picocom -b 115200 /dev/ttyACM0

Regards, Gaute

Doesn’t work with 9600 baud rate either.

Hi @gauteh,

I’m going to guess that you’ve tried these common troubleshooting tasks, but this is where I would start:

  1. Does the device power on (do you see a flashing LED when plugged in)?
  2. Have you tried a different USB cable? Different computer maybe?
  3. How did you perform the firmware update? And which Notecard are you using?


The device is working, connected with i2c to an mcu and has contact and functions as it should. firmware update first over the air, and then also tested using stm32programmer. the usb cable is tested with notecards/carriers hundreds of times.

Thanks, Gaute

Downgrading the firmware to 6.1.1 makes trace work again.

Hi @gauteh,

This is very curious. I wonder if there was an issue with the 6.2.2 upgrade process that led to that error state. If you’re willing, I’d be curious if trying the 6.2.2 upgrade again ends up resolving the issue.