Unable to get the sparkfun qwiic working

Hi There,

I am following the tutorial here …


For the sparkfun carrier with notcard and artemis mcu.

Talking to the notecard directly is working fine and I can transmit data. Hooking up to the artemis via the qwiic connector and powering from PC via the artemis usb-c (and for good measure separate power to the notecard just in case that was the issue).

This is the arduino sketch

#include <Notecard.h>

#define serialDebug Serial

#define productUID "uk.org.digicatapult.pat.molloy:sparkfunqwiic"

Notecard notecard;

void setup() {
  // put your setup code here, to run once:



  J *req = notecard.newRequest("hub.set");
  JAddStringToObject(req, "product", productUID);
  JAddStringToObject(req, "mode", "continuous");


void loop() {
  // put your main code here, to run repeatedly:


Serial monitor is returning

09:37:35.233 -> notecard not responding
09:37:35.233 -> notecard not responding
09:37:35.280 -> notecard not responding

Is there a step messing somewhere? Seems the artemis is not talking to the notecard down the i2c interface …



Hey @patmalloy, thanks for the question, and welcome to the community! Sorry to hear you’re having issues getting the Artemis to talk to the Notecard. I have that board and the Qwiic carrier, so I’ll take a look and see if I can spot the issue.

Incredibly kind. Thanks!

Hey @bsatrom, any luck with this?

I’ve actually tried with a couple of other sparkfun qwiic enabled boards (e.g. SparkFun Thing Plus - SAMD51 - DEV-14713 - SparkFun Electronics) but cannot get those to play nice either.

Making me think there is something amiss with the quiic notecard carrier?


Hi @patmolloy not yet, no. We are still investigating. I actually think it might be an issue with the Note-Arduino library and the Wire implementation that SparkFun uses by default, but I need to dig deeper. Thanks for trying on a SAMD51 as well! I was wondering if it was an Apollo/Artemis issue, but it would seem to not be the case.

Actually on the SAMD51 I get no output on the serial debug at all! I’ll try some other qwiic boards too - I have one based on the new RPi2040 but I have a feeling that is going to be trouble!

Ok, just a bit more info. Today I received a sparkfun ESP32 Thingy Plus board (with qwiic) and this does work. Exactly the same script. I see the correct chatter/handshakes in the serial debug window. So it looks like the carrier board does actually work and the notecard worked all along, of course. Not sure if that helps, actually.

1 Like

Hi, I’m new here. Figured I should check the forums before buying the hardware for my next project, rather than afterwards…

Was the initial issue solved or is the moral of the story to just use a ESP32 Thing plus for now? Patmolloy, was this the one you got working: SparkFun Thing Plus - ESP32 WROOM - WRL-15663 - SparkFun Electronics


Hi there,

The Artemis issue has not yet been resolved as far as I know and I never got the SAMD board working either.

The Sparkfun Thing Plus model I bought was this https://shop.pimoroni.com/products/sparkfun-thing-plus-esp32-wroom-u-fl but it’s identical to the 15663 except it has a u.fl antenna connector.

This does work perfectly!


Hey @cveen thanks for posting, and welcome to the community! Unfortunately, we’ve not yet gotten a resolution on this. We suspect it’s an issue with the Artemis Arduino Core port, but haven’t been able to run it down quite yet.

Wow - thanks for getting back to me so quickly! That’s a sign of a good community.

1 Like

Hey @cveen and @patmolloy it looks like we’ve identified the issue. This fix is unique to the Artemis Thing Plus, but we were able to get things back on track by adding the following before notecard.begin() in a sketch:


Try that out and let us know if that fixes things for you all as well!

Very cool. Very obscure!

Will give it a go.

Thanks for your persistence and following up!

Ah, I2C clock speed!

I ended up getting the SparkFun Thing Plus - ESP32 WROOM (15663) for my project, which worked fine out of the box.

Thanks for the followup!