Swan and Notecarrier F - notecard not detected

Working through the quickstart guides for new development kit with a Swan 3.0 and Notecarrier F. No issues until I tried to initialize over I2c with notecard.begin() - notecard not detected. Using Arduino IDE with Notecard library 1.4.5

I tried an I2C scanning sketch and it found no devices. Moved the notecard to the RPi hat and I2C worked perfectly with a RPi4.

Feather PWR switch is on. Also tried separate power for Swan & Notecarrier but no luck. Any ideas?

Thank you for running the sanity check and making a new post! :+1:

If you’re in a position to share your code, I’d love to have a look. Also, if you would send a picture of your hardware then maybe I could see something that is not obvious to someone new to Blues.


1 Like

Hi Zak - thanks for the quick reply. Here’s the code and pic:

#include <Notecard.h>
#define serialDebug Serial
#define productUID "com.gmail.baileje1:wg_hivemon"

Notecard notecard;
void setup (void) {
  while (!serialDebug) {
    ; // wait for serial port to connect. Needed for native USB
  serialDebug.println("Starting notecard...");

  J *req = notecard.newRequest("hub.set");
  JAddStringToObject(req, "product", productUID);
  JAddStringToObject(req, "mode", "continuous");

void loop (void) {


Turns out even though the Feather PWR switch looked like it was on… it wasn’t. Everything started working once I toggled the Notecarrier switches off & back on. Should have known better.