Notecard not responding

Hi, I am new to but I am trying to use the tutorials and example code to connect and test my notecard. I am using Notecarrier-F and Adafruit Feather M0 Adalogger, but when I run the code (the micro-USB is connected to the Adalogger, not the Notecarrier), I keep getting the response that the notecard is not responding. I know that that Notecarrier and Notecard are working though because it worked when the micro-USB was connected to the Notecarrier directly, but as soon as the microcontroller came into picture, and I started writing code to access it, it stopped working.

This is the code I am using:

#include <Notecard.h>

#define usbSerial Serial
#define productUID “I put my project UID here”

Notecard notecard;

void setup() {
// put your setup code here, to run once:


J *req = notecard.newRequest(“hub.set”);
JAddStringToObject(req, “product”, productUID);
JAddStringToObject(req, “mode”, “continuous”);


void loop() {
// put your main code here, to run repeatedly:


1 Like

I was having the same issue. The Swan Micro controller on the notecarrier not powering the notecard on the Notecarrier…I just now plugged the microcontroller with power applied into the pins on the notecarrier…and it seems to have kickstarted the notecard and is now running.

1 Like

Hi @sbu! Welcome to the Blues Community.

Your setup as you described should work - the Notecarrier-F and Notecard can be powered by the Feather alone, although it’s recommended you power both Notecard and the Feather. It’s perfectly safe to provide USB power to both the Notecarrier and your Adafruit Adalogger. Using that configuration should get you up and running until we can find the underlying cause.

With power supplied to just the Adalogger, do you see any LED activity on the Notecard when power is shut off and then switched on? On boot, the Notecard flashes the red LED in a pattern that starts out slow and gets faster. Please let me know if you see that, or not when supplying power.

What is the version number printed on your Notecarrier?

If you have access to a multimeter, measuring some voltages may help diagnose the issue.

With the Adalogger removed from the Notecarrier and connected to USB power, so that it’s free standing, please measure the voltage across these pairs of pins on the Adalogger:

  • GND and USB
  • GND and 3V3

Then remove power, and insert the Adalogger into the feather socket on the Notecarrier and then reconnect USB power to the Adalogger, without USB power to the Notecarrier.

Then measure voltages between these pins on the Notecarrier. If your Notecarrier has headers installed, you can use male to male jumper cables to make this easier.

  • GND and F_3V3
  • GND and VMAIN
  • GND and N_VIO

Please add a jumper cable between N_EN and F_3V3 on the Notecarrier. Does that bring the Notecard to life?

Finally, take a look at the Feather PWR DIP Switch on the Notecarrier, please check that it is in the ON position.