Web.post fails after switching to continuous mode

  1. My card was in periodic mode.
  2. Did a hub.set to put it in continuous mode
  3. Checked with hub.get that it worked:

hub.get {‘sn’: ‘STX970’, ‘mode’: ‘continuous’, ‘host’: ‘a.notefile.net’, ‘product’: ‘com.XXXXX.francois.demo’, ‘device’: ‘dev:XXXXXXXXXXXX’, ‘sync’: True, ‘inbound’: 60, ‘outbound’:

  1. Tried to do a web.post

{‘err’: ‘web operations require being online (hub.set)’}

  1. Tried a card.restart and even a power down, made no difference.

M1 Notecard connected via USB to Pi3B+

Strangely, the normally flashing green light on the Notecard is off – no activity unless I issue a req command. Other Notecards have green LED activity. Did the “continuous” mode not take?

This is quite odd. Just out of curiosity, what firmware version are you currently running?

Francois - this is odd. I think we need to get you up to our latest RTM firmware version. It looks like all your devices are on 11758.

Issue resolved by upgrading to 12200: now the Notecard stays in continuous mode.


That’s great news. Thanks @Francois!