Wifi notecard not connecting to the wifi accesspoint


I have just started using notecard wifi with notecarrier AF. The issue is in connecting to the wifi network. I am able to send commands to it via browser but I am not able to connect it to wifi access point.

I get the following response… Can anyone help?

> {"req":"hub.sync.status"}
 "status": "wifi: can't join: sl_status:33",
 "sync": true,
 "requested": 11

I also tried the second method which is to connect via mobile phone but it is not showing up in the wifi devices.

Hi @ujur007,

The most common cause of that error is that either the SSID name does not match that of the Access Point or the password does not match. Perhaps you could try re-setting these using card.wifi card Requests - API Reference - Blues Wireless Developers.
Please note that the Notecard Wifi can only connect to 2.4GHz SSIDs.

By the “second method” I assume that you mean you pressed the “AP” button on the Notecard Wifi and attempted to connect to the Notecard with your phone ? Note that it takes around 20 seconds for the SoftAP to be available after pressing this button - it’s worth refreshing the list of Wifi devices on your phone or tablet a few times to see if the Notecard access point will show up.

Sean Taylor, Blues Wireless

Hi @seant

Thanks for reply.

I am using JSON commands as of now from the browser. On the settings of the portable hotspot, everything is okay. I am entering the right SSID and password.

I have tried changing these fields to simple names in order to connect, but no luck. I also reconnected my notecard to the carrier but still, the issue is there. I have connected the uFL antenna on the MAIN pins.

I have also only set up 2.4Ghz mode.

Yes, I mean the pressing of AP button on the notecard and connecting it with the phone. sadly, I dont see the notecard in the list. I have now tried many times.



Could low power be an issue? I am using usb supply from my laptop with both feather and notecard attached to the carrier AF.

Let me try.


It seems the problem is solved, I have removed the feather from the carrier and now I could see the notecard in my cellphone’s wifi list.


Hi @ujur007
Thank you for your persistence and for following up here.
Does the Notecard now connect to the Wifi and sync ? And does it do so when the feather is attached to the Notecarrier ?

Some feathers are very power hungry - the ESP32 in particular, and we have seen problems running an ESP32 feather and a cellular Notecard from a single USB power supply. This was solved by connecting a USB cable to the Notecarrier AND the feather. However I’m surprised that this problem would occur with a Notecard Wifi since the peak current consumption is somewhat lower than cellular.

If the feather is an ESP32 is the ESP32’s Wifi disabled ? I ask because having two Wifi transceivers in such close proximity might lead to interference issues (I am speculating - I have not personally seen a problem, but neither have a used a Wifi enabled feather with a Notecard Wifi).


Hi @seant

Sorry for the late reply. I received the notecard yesterday only.

The notecard is now connecting to the wifi and it is also sync. It does not do so when the feather is attached to the Notecarrier.

I do not have an ESP32 feather rather I have a swan.

I had such an issue with ESP32 previously where the Wifi was not connecting due to USB power.
From there I got the idea to try without feather attached.


I am experiencing the same issue with a WiFi notecard v1.2, Notecarrier AF v1.7.

Without a Feather installed I can get the card to connect to the WiFi.

When a Feather is installed, it fails to connect and eventually provides a sl_status:33`. I have tried various Feather boards and encountered the same issue, so I don’t believe it’s related to the type of Feather installed.

{"sync": false, "req": "hub.sync.status"}
{"status":"wifi: can't join: sl_status:33","sync":true,"requested":21}

I don’t believe it’s a power-supply issue, this occurs if it’s powered using an external power supply rated at 0.4A or both USB ports are connected (i.e the Feather port and the Notecarrier). I have measured the voltage and current draw on the USB ports as well and they appear normal.

I do not have issues with the Cellular notecards using the Notecarrier AF and Feather.

@seant, I’m happy to run additional tests or experiments if you believe it will help isolate the issue.