Airnote not updating new Notecard Firmware

On an Airnote I have here in Nara, I can not update it. It is stuck at 0% and any effort I tried to get it restarted fails. Any suggestion on how to reset the upgrade mode? I have log file if needed.

Rob Oudendijk

From the terminal:

S842:17.38 env: dfu updated:
 "card": {
  "type": "card",
  "file": "$20210612142038.bin",
  "mode": "downloading",
  "status": "$20210612142038.bin",
  "began": 1623900374,
  "retry": 1623900318,
  "info_storage": "file:data/card.json",
  "bin_storage": "file:data/card.bin",
  "updated": 1623900374,
  "version": "{\"org\":\"Blues Wireless\",\"product\":\"Notecard\",\"version\":\"notecard-1.5.3\",\"ver_major\":1,\"ver_minor\":5,\"ver_patch\":3,\"ver_build\":12457,\"built\":\"Feb 19 2021 13:45:28\"}"

Hi @robouden,

Can you walk me through the process you’ve taken to update your Airnote’s Notecard firmware? I’d like to reproduce this locally with mine to see if there is a glitch in the process.


First I tried from the to update the Notecard with new firmware, just like I did a few other Airnotes. That works normally fine. This particular Notecard, started with updating, but stopped. I tried many things, even use a dev board (that could have made it worse I think). I can make a log file and show if you want that. The NoteCard had issue with communicating before. I really would like to completely remove the downloaded data and start “fresh”. How to do that?



Sorry for the delay. I was able to update my Airnote’s Notecard firmware successfully using Notehub (which is a good thing), but it doesn’t help you here. For a manual firmware update you can download the 1.5.5 binary here and follow the instructions on the manual firmware update post.

1 Like


NP for the delay. You must have been busy.
Thanks for the link to the file and the link to the instruction.I will try later today.