Error upgrading Notecard using USB in-browser terminal

Hi, using the USB in-browser terminal and tried to upgrade the firmware from 1.5.6 to latest (7.2.2). Here’s what I got:

DeviceUID dev:864622040824290 (NOTE-NBNA-500) running firmware

Hint: A newer firmware, notecard-7.2.2 (2024 Q2 Developer Release), is available. See Notecard Firmware Updates

> firmware install latest
* Error installing firmware: Error: Could not initate dfu.put: unknown request type: dfu.put {io}.

Is this because this Notecard is too down-level (1.5.6) and needs a lower-level version (say, 3.X.X) to operate in DFU mode? If so, how does one upgrade the NoteCard to that level? Is there a tutorial on how to do this? Thanks!

Hi @drewcssv!

Wow, that’s some “classic” firmware! :sweat_smile:

For older firmwares, you must use the Notehub UI to update the Notecard. Once that is complete, then you will be able to use the WebREPL from

We have a guide to help walk you through the process.


1 Like

Thanks @zfields this worked well and now current at 7.2.2.

1 Like