SILabs driver for Mac Big Sur

I am trying to follow the Sensor tutorial using Macbook Pro and Notecard AF dev package.

I have installed the 6.01 SI Labs driver but it will not load under Big Sur. After researching, it appears that Apple has decided that these type of system extensions are not going to be possible under Big Sur. I have tried csrutil disable but this does not impact the issue

  1. Has anyone found a workaround to this ?
  2. Is there a way to have Adruino use a different method to download to the ESP32 without the SILabs driver ?


Resolved. Newbi mistake of plugging the usb cable into the port on the NoteCard AF rather than the usb port of the ESP32.

Hi @emerson52241 and welcome to the Blues Wireless community!

I ran into a similar problem a few months ago with Big Sur on my M1 mac. Based on what Iā€™m reading now, though, you may not even need to install the driver:

Specifically this comment:

In case it can help someone else what worked with me after weeks of installing/uninstalling the 6.0.1 driver. I had to remove the SiLabs driver altogether and now it just works. Looks like Big Sur has support for that chip built in.

1 Like

Ha, looks like we overlapped our replies :slight_smile:

Please let me know if you run into any other issues!