Using Adalogger Featherwing with Swan

Hi there,
I’m trying use an Adafruit Adalogger Featherwing (Product ID: 2922) with the Swan dev kit (Swan v1.7, Notecarrier-F v1.0).

Using the Arduino default SD library, and the example sketch: CardInfo.

The card has been formatted using the SD card formatter from SD-3C,LLC using the Overwrite Format option (also tried with the Quick Format option).

When not seated in the Notecarrier (i.e. only the Swan + Featherwing), the card partitions are seen and I get the expected list of files.

When seated in the Notecarrier I get:
“Wiring is correct and a card is present.
Could not find FAT16/FAT32 partition.”

Have searched various forums but haven’t found any clues yet.

Any / all suggestions much appreciated.


1 Like

Hey @noforan thanks for the question and welcome to the Blues community! We’re glad you’re here!

Can you send a picture of your fully-assembled set-up with the Adalogger? Also, is there, by any chance, a trace on the Adalogger that would allow you to cut the pull-ups on the I2C lines? Given that everything works without the Notecarrier and doesn’t when you add the Notecard and Notecarrier into the mix, I have a sneaking suspicion that the 10K resistors on the SDA/SCL lines are causing an issue once the Notecard and its built-in pullups on the I2C bus are added into the mix.

Are you able to communicate with the Notecard in this arrangement, even when the Adalogger is throwing the error you described?


Thanks Brandon.

Um, actually it turns out that the problem was totally self-inflicted. :roll_eyes:
But your suggestion pushed me to realize the problem.

I have two nearly identical builds, where I’m comparing a separate breakout board, with the stacking featherwing I described above. Once I started taking pics of the build that I installed the featherwing in, I realized that it was the one that already had the separate SD break out board (duh…), so I’m assuming it created a conflict since they were both trying to use the same SPI pins (MISO, MOSI, etc.). Once I reinstalled the featherwing in the other build, it worked fine.

So, sorry for the false alarm, but it seems to work as advertised.

The Featherwing does use I2C for the RTC, which I’m not planning on using since I can pull timestamps from the Notecard, but I haven’t tested that side yet and haven’t noticed any adverse impact on anything else.

Thanks again!!

1 Like