Lost connection to reference node

I received a Sparrow Development Kit and followed the quickstart guide. I was receiving sensor information from the two reference nodes with no problems for about 2 weeks. Now I am not receiving any information from one of the nodes although the second node’s sensor readings are still being received and recorded.

I could not find any information on how to find any information to help resolve why the link failed. I am also unsuccessful trying to get the reference node to re-link to the Notecard.

I tried to re-link the reference node. The Essentials board is showing a constant green LED and a constant blue LED. The reference node display a blue LED and a red LED about every 25 seconds.

Hey @marvin, and welcome to the Blues community :slightly_smiling_face:

The first thing you might want to try is pressing and holding the PAIR button on the sensor node for 30 seconds, which will restore it to factory settings, and then trying to pair again.

The other thing you might want to try is new batteries in the sensor node, just to ensure it has enough voltage to transmit the readings.

You might find this guide to button and LED behaviors useful as you try things out: Sparrow Hardware Behavior - Blues Wireless Developers.

Hopefully one of these resolves the problem for you, and please let us know how it goes as this is really valuable feedback.


Thanks for the rapid response. I wasn’t very scientific so I don’t know which action actually fixed it. I reset the sensor to factory settings and replaced the battery and it started working again.

Awesome! Glad you got it back up and running.