FTDI-debugging with Notecarrier B v2


I am having trouble getting FTDI-debugging working with the new Notecarrier B. I have had this work before with the green version. I connect AUXEN to VIN og VIO, AUX-RX/TX as described in the tutorial. And the black FTDI cable to one of the GND pins on the notecarrier B.

I get a /dev/ttyUSB0 on Ubuntu Jammy which I use with picocom at baudrate 115200, but no output and no response when typing trace. This works well when I use a USB to the Notecarrier B with picocom and /dev/ttyACM0.

Regards, Gaute

Hi @gauteh,

I just tried using my FTDI cable with the new Notecarrier-B, and all works fine. Following these instructions, I bridged AUXEN to VUSB and VIO and both worked fine.

I’m not quite sure what the issue could be (unless there is a mistake in your wiring?), but do you have another Notecarrier-B you could try?


Thanks for checking, I’ll try another one as well. Could there be any missing setup with the FTDI driver on Ubuntu?

( I’ve quadruple-checked the wiring, and inverted RX/TX just for good measure as well… )

Hi @gauteh!

Great to see your name again!

I just so happen to be setting up a brand new Linux machine with Ubuntu 22.04 today. I’ll give it a check and see if I run into the same issue.

Hi Zach! Great to hear from you as well! Thanks!

I’m tuning power use, down to 40 mW on average (including syncs and GPS) with continuous logging and an ahrs algorithm.

1 Like

Hello Gauteh,

I finally got to test my new Ubuntu 22.04 laptop (fresh install) with this FTDI cable, and it just worked, with no additional drivers. I hooked a battery to the Notecarrier B and used the pinout shown in the table below:


I hooked the Notecarrier B pins AUXEN and VIO together, directly.

Once everything is connected, don’t forget to issue the {"req":"card.trace","mode":"on"} command to see logs.

Check out this related topic for more information: