Lora Wan configuration

I just got my lora wan module and it doesn’t work the way I thought.

I have been using Wio-E5 lora device that is connected to the things network.

I was expecting that this unit would connect to the things network and show up as a new device in the things network but does not and shows up on Notehub. How did it get there, and can I use this device on the Things Network?

Hi @iseries1 and welcome to the Blues community!

I can appreciate your confusion around how the Notcard LoRa works with The Things Stack and Notehub. It’s a bit of a different paradigm than what people are used to. If you’re using one of the pre-provisioned gateways that we offer, your data flows like this, with Blues managing the network and app server on The Things Stack:

If you’re using a different TTN gateway, the flow is similar, but you can see/manage the device on your own network server:


That’s the thing though. I have my own Gateway that I have been using with the previous product and since I am not using the TheThings Cloud I don’t have access to the Packet Broker and yet it shows up in Notehub.
I do see the traffic going through my gateway though.
Can I register this device on The Things Stack and what do I use for the values.

Hi @iseries1,

The Notecard LoRa doesn’t show up as an End Device in your Things account because we manage all Notecard LoRa devices in our own Things Stack tenant (which end users won’t ever see because they are associated with our Application Server). If data is showing up in Notehub, which it is, all is good!


Hi, I’m trying to connect my Lora notecard to notehub via The Things Stack, but without results. My gateway (Rak7268) is connected to The Things Stack but when I try a hub.set with my Notecard, it doesn’t connect. Any advices?
Thank you,

You used this command and it failing:
{“req”:“hub.set”, “product”:“com.your-company.your-name:your_product”}
You replaced the “com.your-company.your-name:your_product” with your Product UID you setup for your project.
That’s all I did and it worked like magic.


Hi, I did the hub.set protocol and then the hub.sync but the Notecard cannot connect. I receive an {extended-network-failure}. It looks like it didn’t see my Gateway. It’s my first time with The Things Stack plateform, so maybe there is a problem with the configuration.

@ouaibeer , That’s odd. The LoraWan Gateway listens on a default port and should just work. I did no configurations on my gateway other than I had it already setup for The Things Network with the old devices.

I can see the traffic when looking at my Gateway, but can’t tell anything based on the received data.


Hi @ouaibeer - is packet broker enabled on your gateway? That’s the first thing I would check!

I have a cloud discovery account. I don’t have the Packet Broker button with this account. The standard account cost 190$/month so not realy a good solution for me. I asked the Things Industry support if they can give me access to the Paquet Broker, I will see. Thank you for your help. Eric

Hi @ouaibeer. Packet Broker should be supported on Cloud Discovery, Standard, or Plus. It is only not supported with the Sandbox account. You can find more information at the link below:-

If you want to enable this on your account, follow the steps below:-

  1. Go to Admin Panel → Peering Settings.

  1. Enable the Packet Broker toggle switch.

  2. Select “Forward traffic to all networks registered in Packet Broker“.

If you don’t see peering settings in your account then you are most likely on a Things Stack Sandbox accound and not a Cloud Discovery account. You can sign up for free for a Cloud Discovery account at the link below (you will still have to provide payment details in case you switch in the future).


I hope this helps.

Hi @Youssif, thank you very much that was the “Forward traffic…” which was wrong on my config. Now it’s working great! I think blues @RobLauer could explain a little bit better how to configure a non blues Gateway, your screenshot @Youssif was very helpfull. Thank you all for your help.